increase dvbapp PR.
[vuplus_openembedded] / recipes / ezx / ezxd_svn.bb
1 DESCRIPTION = "Open implementation of motorola's tapisrv, replaces opentapi"
2 LICENSE = "GPLv2"
3 SECTION = "devel"
4 AUTHOR = "Daniel Ribeiro"
5
6 PV = "0.0+svnr${SRCPV}"
7 PR = "r4"
8
9 SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=ezxd;proto=http \
10            file://ezxd.init \
11           "
12
13 inherit update-rc.d
14
15 INITSCRIPT_NAME = "ezxd"
16 INITSCRIPT_PARAMS = "start 00 S ."
17
18 S = "${WORKDIR}/${PN}"
19
20 CFLAGS_append = " -DDEBUG " 
21
22 TARGET_CC_ARCH += "${LDFLAGS}"
23
24 do_configure() {
25         sed -i -e s:CROSS:CC:g Makefile
26 }
27
28 fakeroot do_install() {
29         install -d ${D}/dev/input
30         mknod ${D}/dev/input/uinput c 10 223
31
32         install -d ${D}${bindir}
33         install -m 755 ezxd ${D}${bindir}
34
35         install -d ${D}${libdir}/ezxd
36         install -m 755 *.so ${D}${libdir}/ezxd
37
38         install -d ${D}${sysconfdir}/init.d
39         install -m 0600 ezxd.conf ${D}${sysconfdir}/
40         install -m 0755 ${WORKDIR}/ezxd.init ${D}${sysconfdir}/init.d/ezxd
41 }
42
43 FILES_${PN} += "/dev"
44 CONFFILES_${PN} += "${sysconfdir}/ezxd.conf"
45