Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / recipes / ezx / ezx-gpiotool_1877.bb
1 DESCRIPTION = "Gpiotool can read/write gpio configuration from userspace."
2 SECTION = "devel"
3 LICENSE = "GPL"
4 HOMEPAGE = "http://www.openezx.org"
5 AUTHOR = "Harald Welte"
6 PR = "r0"
7
8 SRC_URI = "svn://svn.openezx.org/trunk/src/userspace;module=gpiotool;proto=http;rev=${PV}"
9 S = "${WORKDIR}/gpiotool"
10
11 do_compile() {
12         for i in mmio.c gpiotool.c gpio.c
13         do
14                 ${CC} ${CFLAGS} -c $i
15         done
16         ${CC} ${CFLAGS} -o ezx-gpiotool mmio.o gpiotool.o gpio.o
17 }
18
19 do_stage() {
20         :
21 }
22
23 do_install() {
24         install -d ${D}${sbindir}
25         install -m 0755 ezx-gpiotool ${D}${sbindir}
26 }