increase dvbapp PR.
[vuplus_openembedded] / recipes / ez-ipupdate / ez-ipupdate_3.0.10.bb
1 # Angus Mackay's ez-ipupdate from www.ez-ipupdate.com
2 DESCRIPTION = "A client for automatically updating your EZ-IP.net, justlinux.com, dhs.org, dyndns.org, ods.org, gnudip.cheapnet.net, tzo.com, easydns.com dynamic hostname parameters. Includes daemon support that only sends updates if your IP address changes."
3 HOMEPAGE = "http://www.ez-ipupdate.com/"
4 SECTION = "console/network"
5 PRIORITY = "optional"
6 LICENSE = "GPL"
7 PR = "r1"
8
9 SRC_URI = "http://www.ez-ipupdate.com/dist/ez-ipupdate-${PV}.tar.gz \
10            file://configure.patch;patch=1 \
11            file://conffile.patch;patch=1 \
12            file://zoneedit.patch;patch=1 \
13            file://init \
14            file://ipupdate.conf \
15           "
16
17 INITSCRIPT_NAME = "ipupdate"
18 # No dependencies, so just go in at the standard level (20)
19 INITSCRIPT_PARAMS = "defaults"
20
21 # The configuration file must be editted...
22 CONFFILES_${PN} = "${sysconfdir}/ipupdate.conf"
23
24 inherit autotools update-rc.d
25
26 do_install_append() {
27         install -d "${D}${sysconfdir}/init.d"
28         install -c -m 755 ${WORKDIR}/init "${D}${sysconfdir}/init.d/ipupdate"
29         install -c -m 644 ${WORKDIR}/ipupdate.conf "${D}${sysconfdir}/ipupdate.conf"
30 }