update driver
[vuplus_openembedded] / recipes / etherpuppet / etherpuppet_0.2.bb
1 DESCRIPTION = "Etherpuppet is a small program for Linux that will create a \
2 voodoo doll for an Ethernet interface. You have to run the Etherpuppet on \
3 your machine to create the doll, which will have the shape of a virtual \
4 TUN/TAP interface (named by default puppet%d, where %d is a number). \
5 You also have to run Etherpuppet on the victim interface's machine."
6 SECTION = "console/network"
7 LICENSE = "LGPL"
8
9 SRC_URI = "http://www.secdev.org/projects/etherpuppet/files/etherpuppet.c"
10 S = "${WORKDIR}"
11
12 do_unpack() {
13         install -m 0644 ${DL_DIR}/etherpuppet.c ${S}
14 }
15
16 do_compile() {
17         ${CC} ${CFLAGS} ${LFLAGS} -o etherpuppet etherpuppet.c
18 }
19
20 do_install() {
21         install -d ${D}${sbindir}
22         install -m 0755 etherpuppet ${D}${sbindir}
23 }
24