fix task-vuplus-enigma2.bb
[vuplus_openembedded] / recipes / espgs / espgs_8.15.3.bb
1 DESCRIPTION = "ESP Ghostscript is an up-to-date GNU Ghostscript distribution \
2 including bug fixes, new drivers, and additional support for CUPS."
3 HOMEPAGE = "http://www.cups.org/espgs/"
4 SECTION = "libs"
5 DEPENDS = "jpeg zlib libpng tiff fontconfig"
6 LICENSE = "GPL"
7 PR = "r1"
8
9 SRC_URI = "http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/ghostscript/${PV}/espgs-${PV}-source.tar.bz2"
10
11 PARALLEL_MAKE = ""
12
13 inherit autotools
14
15 EXTRA_OECONF = "--with-drivers=ALL \
16                 --enable-cups \
17                 --without-ijs \
18                 --disable-gtk \
19                 --without-gimp-print \
20                 --without-x \
21                 --without-omni"
22
23 do_compile() {
24         oe_runmake CCAUX="${BUILD_CC}"
25 }
26
27
28 do_install () {
29         oe_runmake 'prefix=${D}${prefix}' \
30                    'bindir=${D}${bindir}' \
31                    'datadir=${D}${datadir}' \
32                    'cups_datadir=${D}${datadir}/cups' \
33                    'cups_serverroot=${D}${sysconfdir}/cups' \
34                    'cups_serverbin= ${D}${libdir}/cups' \
35                    'CUPSSERVER=${cups_serverbin}' \
36                    'CUPSCONFIG=${cups_serverroot}' \
37                    'CUPSDATA=${cups_datadir}' \
38                    'sysconfdir=${D}${sysconfdir}' \
39                    'gsdir=${D}${datadir}/ghostscript' \
40                    'gsdatadir=${D}${datadir}/ghostscript/8.15' \        
41                    'mandir=${D}${mandir}' \
42                    'docdir=${D}${datadir}/doc/espgs/' install                              
43 }
44
45 PACKAGES += "espgs-examples espgs-resources"
46
47 # I added the lib dir to the central package, since espgs complained of a missing file when run.
48 # If I find exactly which files are needed for operation, I'll just add those, and split the package.
49
50 FILES_${PN} += "${datadir}/ghostscript/8.15/lib/* \
51                 ${libdir}/cups/filter/* \
52                 ${datadir}/cups/model/* \"
53 FILES_${PN}-doc += "${datadir}/ghostscript/8.15/doc/*"
54 FILES_${PN}-examples += "${datadir}/ghostscript/8.15/examples/*"
55 FILES_${PN}-resources += "${datadir}/ghostscript/8.15/Resource/*"