Merge commit 'oe/org.openembedded.dev' into opendreambox
[vuplus_openembedded] / recipes / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
4         dreambox-dvbincludes freetype libdvbsi++ python swig-native  \
5         gstreamer gst-plugins-good gst-plugins-bad gst-plugins-ugly \
6         gst-plugin-dvbmediasink gst-plugin-fluendo-mpegdemux \
7         libfribidi libxmlccwrap libdreamdvd tuxbox-tuxtxt-32bpp"
8 RDEPENDS = "python-codecs python-core python-datetime python-elementtree \
9         python-fcntl python-io python-math python-lang python-re \
10         python-stringold python-threading python-xml gst-plugin-decodebin \
11         gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
12         gst-plugin-typefindfunctions gst-plugin-ivorbis gst-plugin-audioconvert \
13         gst-plugin-wavparse python-netclient gst-plugin-mpegstream gst-plugin-selector \
14         gst-plugin-flac gst-plugin-dvbmediasink gst-plugin-fluendo-mpegdemux \
15         gst-plugin-neonhttpsrc gst-plugin-mpegaudioparse gst-plugin-subparse \
16         eglibc-gconv-iso8859-15 \
17         ${@base_contains("MACHINE_FEATURES", "alsa", \
18                 "gst-plugin-alsa alsa-conf", "gst-plugin-ossaudio", d)}"
19
20 RDEPENDS_append_dm8000 = " gst-plugin-avi gst-plugin-matroska gst-plugin-qtdemux \
21         gst-plugin-cdxaparse gst-plugin-cdxaparse gst-plugin-cdio gst-plugin-vcdsrc"
22 RDEPENDS_append_dm800 = " gst-plugin-matroska gst-plugin-qtdemux"
23
24 DESCRIPTION_append_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
25 RDEPENDS_enigma2-plugin-extensions-cutlisteditor = "aio-grab"
26 DESCRIPTION_append_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
27 DESCRIPTION_append_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
28 DESCRIPTION_append_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
29 DESCRIPTION_append_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
30 DESCRIPTION_append_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
31 DESCRIPTION_append_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
32 DESCRIPTION_append_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
33 DESCRIPTION_append_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
34 RDEPENDS_enigma2-plugin-systemplugins-hotplug = "python-pkgutil"
35 RDEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
36 RDEPENDS_enigma2-plugin-extensions-dvdburn = "cdrkit dvdauthor dvd+rw-tools mjpegtools projectx python-imaging"
37 RDEPENDS_enigma2-plugin-systemplugins-nfiflash = "python-twisted-web"
38
39 export LD="${CXX}"
40
41 PN = "enigma2"
42 PR = "r0"
43 SRCDATE = "20090214"
44 SRCREV = "935c5f9abeb0d6189c57f8406855d8437db8b0db"
45
46 # if you want experimental, use:
47 REL_MAJOR="2"
48 REL_MINOR="6"
49 BRANCH = "master"
50
51 # if you want a 2.5-based release, use
52 #REL_MAJOR="2"
53 #REL_MINOR="5"
54 #BRANCH = "enigma2_rel${REL_MAJOR}${REL_MINOR}"
55
56 PV = "${REL_MAJOR}.${REL_MINOR}git${SRCDATE}"
57
58 SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH} \
59         file://enigma2.sh \
60         file://tuxtxt_caching.patch;patch=1;pnum=1"
61
62 SRC_URI_append_dm7025 = " file://enigma2-disable-iframesearch.patch;patch=1;pnum=1 \
63         file://enigma2-disable-hardware-mp3-decode.patch;patch=1;pnum=1"
64
65 S = "${WORKDIR}/git"
66
67 FILES_${PN} += "${datadir}/fonts"
68 PACKAGE_ARCH = "${MACHINE_ARCH}"
69
70 inherit autotools pkgconfig
71
72 bindir = "/usr/bin"
73 sbindir = "/usr/sbin"
74
75 EXTRA_OECONF = "--enable-maintainer-mode --with-target=native --with-libsdl=no"
76
77 do_install_append() {
78         install -m 0755 ${WORKDIR}/enigma2.sh ${D}/usr/bin/
79 }
80
81 python populate_packages_prepend () {
82         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
83
84         do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', '%s ', recursive=True, match_path=True, prepend=True)
85 }
86
87 do_stage_append() {
88         install -d ${STAGING_INCDIR}/enigma2
89         install -m 0644 ${S}/include/*.h ${STAGING_INCDIR}/enigma2
90         for dir in actions base components driver dvb dvb/lowlevel dvb_ci gdi gui mmi nav python service; do
91                 install -d ${STAGING_INCDIR}/enigma2/lib/$dir;
92                 install -m 0644 ${S}/lib/$dir/*.h ${STAGING_INCDIR}/enigma2/lib/$dir;
93         done
94 }