Merge remote-tracking branch 'dm/opendreambox-1.6' into test_0701
[vuplus_openembedded] / recipes / enigma2 / enigma2-plugins.bb
1 DESCRIPTION = "Additional plugins for Enigma2"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3
4 PACKAGES_DYNAMIC = "enigma2-plugin-*"
5
6 # if you want experimental, use:
7 #SRCREV="87fd2f1120962f553ecb1a88bbee46ed821df975"
8 SRCREV="c8fc96e8e51e1ef71e1709f9dd6f733007f9463e"
9 SRCDATE="20110215"
10 BRANCH="master"
11 PV = "experimental-git${SRCDATE}"
12
13 PR = "r1"
14 SRC_URI="git://schwerkraft.elitedvb.net/enigma2-plugins/enigma2-plugins.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
15
16 EXTRA_OECONF = " \
17         BUILD_SYS=${BUILD_SYS} \
18         HOST_SYS=${HOST_SYS} \
19         STAGING_INCDIR=${STAGING_INCDIR} \
20         STAGING_LIBDIR=${STAGING_LIBDIR} \
21 "
22
23 SRC_URI_append_vuplus = " \
24            file://enigma2_plugins_mytube_tpm.patch;patch=1;pnum=1 \
25            file://enigma2_plugins_webinterface_tpm.patch;patch=1;pnum=1 \
26            file://enigma2_plugins_ac3lipsync_dolby.patch;patch=1;pnum=1 \
27            file://enigma2_plugins_autoresolution_fix.patch;patch=1;pnum=1 \
28            file://dreamboxweb.png \
29            file://dreamboxwebtv.png \
30            file://favicon.ico"
31
32 FILES_${PN} += " /usr/share/enigma2 /usr/share/fonts "
33 FILES_${PN}-meta = "${datadir}/meta"
34 PACKAGES += "${PN}-meta"
35 PACKAGE_ARCH = "${MACHINE_ARCH}"
36
37 inherit autotools
38
39 S = "${WORKDIR}/git"
40
41 DEPENDS = "python-pyopenssl python-gdata streamripper python-mutagen python-daap"
42 DEPENDS += "enigma2"
43
44
45 def modify_po():
46         import os
47         try:
48                 os.system("find ./ -name \"*.po\" > ./po_list")
49                 os.system("find ./ -name \"*.pot\" >> ./po_list")
50                 po_list = []
51                 po_list = open('po_list','r+').readlines()
52                 for x in po_list:
53                         changeword1(x)
54                 changeword1('enigma2-plugins/networkwizard/src/networkwizard.xml ')
55                 changeword2('enigma2-plugins/webinterface/src/web-data/tpl/default/index.html ')
56                 os.system('rm po_list')
57         except:
58                 print 'word patch error '
59                 return
60
61 def changeword1(file):
62         fn = file[:-1]
63         fnn = file[:-1]+'_n'
64         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
65         os.system(cmd)
66         cmd1 = "mv "+fnn+" "+fn
67         os.system(cmd1)
68
69 def changeword2(file):
70         fn = file[:-1]
71         fnn = file[:-1]+'_n'
72         cmd = "sed s/Dreambox/Vu+/g "+fn+" > "+fnn
73         os.system(cmd)
74         cmd1 = "mv "+fnn+" "+fn
75         os.system(cmd1)
76
77 do_unpack_append(){
78         modify_po()
79 }
80
81
82 do_install_append_vuplus() {
83         install -m 0644 ${WORKDIR}/dreamboxweb.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
84         install -m 0644 ${WORKDIR}/dreamboxwebtv.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/tpl/default/streaminterface/img
85         install -m 0644 ${WORKDIR}/favicon.ico ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
86 }
87
88 python populate_packages_prepend () {
89         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
90
91         do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', 'Enigma2 Plugin: %s', recursive=True, match_path=True, prepend=True)
92
93         def getControlLines(mydir, d, package):
94                 import os
95                 try:
96                         #ac3lipsync is renamed since 20091121 to audiosync.. but rename in cvs is not possible without lost of revision history..
97                         #so the foldername is still ac3lipsync
98                         if package == 'audiosync':
99                                 package = 'ac3lipsync'
100                         src = open(mydir + package + "/CONTROL/control").read()
101                 except IOError:
102                         return
103                 for line in src.split("\n"):
104                         if line.startswith('Package: '):
105                                 full_package = line[9:]
106                         if line.startswith('Depends: '):
107                                 bb.data.setVar('RDEPENDS_' + full_package, ' '.join(line[9:].split(', ')), d)
108                         if line.startswith('Description: '):
109                                 bb.data.setVar('DESCRIPTION_' + full_package, line[13:], d)
110                         if line.startswith('Replaces: '):
111                                 bb.data.setVar('RREPLACES_' + full_package, ' '.join(line[10:].split(', ')), d)
112                         if line.startswith('Conflicts: '):
113                                 bb.data.setVar('RCONFLICTS_' + full_package, ' '.join(line[11:].split(', ')), d)
114                         if line.startswith('Maintainer: '):
115                                 bb.data.setVar('MAINTAINER_' + full_package, line[12:], d)
116
117         mydir = bb.data.getVar('D', d, 1) + "/../git/"
118         for package in bb.data.getVar('PACKAGES', d, 1).split():
119                 getControlLines(mydir, d, package.split('-')[-1])
120 }