increase dvbapp PR.
[vuplus_openembedded] / recipes / enchant / enchant_1.2.5.bb
1 DESCRIPTION = "Enchant Spell checker API Library"
2 PRIORITY    = "optional"
3 SECTION = "libs"
4 LICENSE     = "LGPL"
5 DEPENDS     = "aspell"
6 RDEPENDS    = "aspell"
7
8 inherit autotools pkgconfig
9
10 PR = "r1"
11
12 S = "${WORKDIR}/enchant-${PV}"
13
14 SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz \
15            file://configure.patch;patch=1"
16
17 EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${layout_prefix} --enable-aspell --disable-binreloc"
18
19 FILES_${PN} = "/usr/bin/* /usr/lib/enchant/*.so /usr/share/enchant /usr/lib/libenchant*.so.*"
20
21 do_stage() {
22         oe_runmake install prefix=${STAGING_DIR_HOST}${layout_prefix} \
23                bindir=${STAGING_BINDIR} \
24                includedir=${STAGING_INCDIR} \
25                libdir=${STAGING_LIBDIR} \
26                datadir=${STAGING_DATADIR} \
27                mandir=${STAGING_DIR_HOST}${layout_mandir}
28 }