dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / enca / enca_1.9.bb
1 DESCRIPTION = "Enca is an Extremely Naive Charset Analyser"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "GPLv2"
5 HOMEPAGE = "http://trific.ath.cx/software/enca/"
6 PR = "r4"
7
8 SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/enca-${PV}.tar.bz2 \
9         file://configure-hack.patch;patch=1 \
10         file://dont-run-tests.patch;patch=1 \
11         file://configure-remove-dumbness.patch;patch=1 \
12         file://makefile-remove-tools.patch;patch=1 "
13
14 inherit autotools
15
16 EXTRA_OECONF="--with-libiconv-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}"
17
18 do_configure_prepend() {
19         # remove failing test which checks for something that isn't even used
20         sed -i -e '/ye_FUNC_SCANF_MODIF_SIZE_T/d' configure.ac
21 }
22
23 do_configure_append() {
24         sed -i s:-I/usr/include::g Makefile
25         sed -i s:-I/usr/include::g */Makefile
26 }
27
28 do_compile() {
29     cd ${S}/tools && ${BUILD_CC} -o make_hash make_hash.c
30     cd ..
31     oe_runmake
32 }
33
34 do_stage () {
35         autotools_stage_all
36 }