Merge commit 'origin/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / em8300 / em8300_0.16.3.bb
1 DESCRIPTION = "Drivers and utils for DXR3/Hollywood+ mpeg decoder cards""
2 DEPENDS = "gtk+"
3
4 # Be sure to have the I2C bitbanging interface enabled in your kernel config
5
6 SRC_URI = "${SOURCEFORGE_MIRROR}/dxr3/${PN}-${PV}.tar.gz \
7            file://kernel-source-dir.diff;patch=1 \
8           "
9
10 inherit module-base autotools
11
12 do_configure_prepend() {
13         sed -i -e s:SEDME:${STAGING_KERNEL_DIR}:g modules/Makefile
14 }
15
16 do_compile_append() {
17        cd ${S}/modules
18        oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR}   \
19                   KERNEL_SRC=${STAGING_KERNEL_DIR}    \
20                   KERNEL_VERSION=${KERNEL_VERSION}    \
21                   CC="${KERNEL_CC}" LD="${KERNEL_LD}" 
22        cd ${S}
23 }
24
25 do_install_append() {
26        cd ${S}/modules
27        unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
28        oe_runmake DEPMOD=echo INSTALL_MOD_PATH="${D}" CC="${KERNEL_CC}" LD="${KERNEL_LD}" modules_install
29        cd ${S}
30
31
32 PACKAGES =+ "em8300-modules"
33 FILES_em8300-modules = "${base_libdir}/modules"
34
35 pkg_postinst_append () {
36         if [ -n "$D" ]; then
37                 exit 1
38         fi
39         depmod -a
40         update-modules || true
41 }
42
43 pkg_postrm_append () {
44         update-modules || true
45 }
46
47