increase dvbapp PR.
[vuplus_openembedded] / recipes / elfutils / elfutils_0.143.bb
1 DESCRIPTION = "A collection of utilities and DSOs to handle compiled objects."
2 SECTION = "base"
3 LICENSE = "OSL"
4 DEPENDS = "libtool"
5
6 inherit autotools
7
8 SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/elfutils-${PV}.tar.bz2 \
9            http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.143-1.diff.gz;patch=1 \
10            file://i386_dis.h \
11            file://x86_64_dis.h \
12 "
13
14 # The buildsystem wants to generate 2 .h files from source using a binary it just built, let's work around that
15
16 do_configure_prepend() {
17     sed -i 's:./i386_gendis:echo\ \#:g' ${S}/libcpu/Makefile.am
18
19     cp ${WORKDIR}/*dis.h ${S}/libcpu
20 }
21
22