increase dvbapp PR
[vuplus_openembedded] / recipes / ekiga / ekiga_git.bb
1 DESCRIPTION = "Gnome videoconferencing application"
2 LICENSE = "GPLv2"
3
4 ARM_INSTRUCTION_SET = "arm"
5
6 DEFAULT_PREFERENCE = "1"
7 PV = "3.2.6+git"
8 PR = "r2+gitr${SRCREV}"
9 SRCREV = "4af42b2f4fd8e6b52c2c578bb4a5d5ad9c26e8f2"
10
11 inherit gnome
12
13 SRC_URI = "git://git.gnome.org/ekiga;protocol=git;branch=gnome-2-26"
14 S = "${WORKDIR}/git"
15
16 DEPENDS += " avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer gst-plugins-good gst-plugins-base gst-plugins-bad opal ptlib gnome-doc-utils"
17 RDEPENDS += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
18
19 EXTRA_OECONF = "--enable-static-libs   --disable-ldap --disable-gnome --enable-gstreamer   --disable-gdu --disable-scrollkeeper "
20
21 do_configure_prepend() {
22         touch gnome-doc-utils.make
23 }
24
25 do_configure_append() {
26         find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
27         find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
28 }
29
30 FILES_${PN} += "${datadir}/dbus-1 ${datadir}/icons"
31