increase dvbapp PR
[vuplus_openembedded] / recipes / efl1 / libeweather_svn.bb
1 DESCRIPTION = "EFL-based weather widget library"
2 LICENSE = "LGPL"
3 DEPENDS = "ecore edje"
4 PV = "0.0.0+svnr${SRCPV}"
5 PR = "r0"
6
7 inherit efl
8
9 EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
10
11 SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/PROTO;module=eweather;proto=http"
12 S = "${WORKDIR}/eweather"
13
14 RSUGGESTS_${PN} = "elementary-tests"
15
16 do_compile_append() {
17         sed -i -e s:${STAGING_DIR_TARGET}::g \
18                -e s:/${TARGET_SYS}::g \
19                   eweather.pc
20 }
21
22 PACKAGES += "${PN}-plugins"
23
24 FILES_${PN}-themes = "\
25   ${datadir} \
26 "
27
28 FILES_${PN}-plugins = "\
29   ${libdir}/eweather/plugins/*.so \
30 "
31
32 FILES_${PN}-dbg += "\
33   ${libdir}/eweather/plugins/.debug \
34 "
35
36 FILES_${PN}-dev += "\
37   ${libdir}/eweather/plugins/*.a \
38   ${libdir}/eweather/plugins/*.la \
39 "
40
41 RRECOMMENDS_${PN} = "\
42   ${PN}-themes \
43   ${PN}-plugins \
44 "