increase dvbapp PR.
[vuplus_openembedded] / recipes / efl1 / epdf_svn.bb
1 DESCRIPTION = "Epdf is the glue between EFL and libpoppler"
2 LICENSE = "MIT BSD"
3 DEPENDS = "poppler evas ecore etk ewl"
4 PV = "0.1.0+svnr${SRCPV}"
5 PR = "r2"
6
7 inherit efl
8
9 SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/PROTO;module=epdf;proto=http"
10 #           file://fix-plugin-path-check.patch;HACK=1;patch=1"
11 # FIXME This package is not really working correctly at the moment. It doesn't
12 # recognize epsilon and doesn't build everything. The next one actually using
13 # this package is welcome to fix it.
14
15 EXTRA_OECONF = "--enable-etk --enable-ewl"
16
17 # add ewl additions
18 FILES_${PN}-dev += "${libdir}/ewl/tests/*.a ${libdir}/ewl/tests/*.la"
19 FILES_${PN}-dbg += "${libdir}/ewl/tests/.debug"
20
21 # add epsilon additions
22 FILES_${PN}-dev += "${libdir}/epsilon/plugins/epdf_thumbnailer.a ${libdir}/epsilon/plugins/epdf_thumbnailer.la"
23 FILES_${PN}-dbg += "${libdir}/epsilon/plugins/.debug"
24
25 PACKAGES += "${PN}-ewl-widget epsilon-plugin-${PN}"
26 FILES_${PN}-ewl-widget = "${libdir}/ewl/tests/libewl_pdf*.so*"
27 FILES_epsilon-plugin-${PN} = "${libdir}/epsilon/plugins/epdf_thumbnailer.so*"
28