Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / recipes / e17 / exquisite-theme-illume.bb
1 DDESCRIPTION = "A theme for exquisite"
2 HOMEPAGE = "http://www.enlightenment.org"
3 LICENSE = "MIT/BSD"
4 SECTION = "x11"
5 PV = "1.0+svnr${SRCREV}"
6 PR = "r6"
7
8 inherit update-alternatives
9
10 ALTERNATIVE_NAME = "exquisite-config"
11 ALTERNATIVE_LINK = "${sysconfdir}/exquisite/config"
12 ALTERNATIVE_PATH = "${sysconfdir}/exquisite/config-illume"
13 ALTERNATIVE_PRIORITY = "10"
14
15 SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk;module=THEMES/b_and_w;proto=http"
16 S = "${WORKDIR}/THEMES/b_and_w"
17
18 do_compile() {
19    edje_cc exquisite.edc illume.edj
20 }
21
22 do_install() {
23     install -d ${D}${sysconfdir}/exquisite
24     install -d ${D}${datadir}/exquisite/data/themes
25     install -m 0644 ${S}/illume.edj ${D}${datadir}/exquisite/data/themes/
26     echo 'THEME="-t illume"' > ${D}${sysconfdir}/exquisite/config-illume
27 }
28
29 PACKAGE_ARCH = "all"
30 CONFFILES_${PN} = "${sysconfdir}/exquisite/config-illume"
31 FILES_${PN} = "${sysconfdir}/exquisite ${datadir}/exquisite/data/themes"