add plugin(streamtvplayer)
[vuplus_openembedded] / recipes / e17 / exalt_svn.bb
1 DESCRIPTION = "Exalt is a network manager for the windows manager Enlightenment DR17."
2 HOMEPAGE = "http://watchwolf.fr/wiki/doku.php?id=exalt"
3
4 LICENSE = "LGPLv2"
5 DEPENDS = "elementary vpnc wpa-supplicant ecore eet edbus"
6 RDEPENDS = "vpnc wpa-supplicant"
7
8 PV = "0.9+svnr${SRCPV}"
9
10 inherit e
11
12 EXTRA_OECONF = " \
13 --with-wpa_supplicant=${sbindir}/wpa_supplicant \
14 --with-vpnc=${sbindir}/vpnc \
15 --with-vpnc-disconnect=${sbindir}/vpnc-disconnect \
16 "
17
18 do_install_append() {
19         # install dbus config file
20         install -d ${D}${sysconfdir}/dbus-1/system.d/
21         install -m 0644 data/daemon/dbus/exalt.conf ${D}${sysconfdir}/dbus-1/system.d/exalt.conf
22
23         # install dbus service file
24         install -d ${D}${datadir}/dbus-1/system-services/       
25         install -m 0644 org.e.Exalt.service ${D}${datadir}/dbus-1/system-services/
26 }
27
28 do_stage() {
29         autotools_stage_all
30 }
31
32 FILES_${PN} += "${datadir}/dbus-1"
33