update driver
[vuplus_openembedded] / recipes / disko / disko_git.bb
1 DESCRIPTION = "Disko is an application framework, that can be used to develop GUI applications for embedded devices. It is closely connected to the DirectFB"
2 LICENSE = "GPL"
3 PV = "1.6.1+gitr${SRCREV}"
4 PR = "r0"
5
6 DEFAULT_PREFERENCE = "-1"
7
8 require disko.inc
9
10 DEPENDS += "taglib directfb virtual/libx11 hal libxv libxxf86vm"
11
12 SRC_URI = "git://www.diskohq.org/disko.git;protocol=git \
13            file://pkgconfig.patch;patch=1 \
14           "
15
16 S = "${WORKDIR}/git"
17
18 do_compile() {
19         ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} graphics=all prefix=${prefix}/ || \
20         oefatal "scons build execution failed."
21 }