increase dvbapp PR.
[vuplus_openembedded] / recipes / diffutils / diffutils_2.8.1.bb
1 SECTION = "base"
2 LICENSE = "GPL"
3 DESCRIPTION = "Diffutils contains the GNU diff, diff3, \
4 sdiff, and cmp utilities. These programs are usually \
5 used for creating patch files."
6 PR = "r4"
7
8 SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz"
9
10 inherit autotools update-alternatives
11
12 # diffutils assumes non-glibc compilation with uclibc and
13 # this causes it to generate its own implementations of
14 # standard functionality.  regex.c actually breaks compilation
15 # because it uses __mempcpy, there are other things (TBD:
16 # see diffutils.mk in buildroot)
17 EXTRA_OECONF_linux-uclibc = "--without-included-regex"
18 EXTRA_OECONF_linux-uclibceabi = "--without-included-regex"
19
20 do_install_append () {
21         mv ${D}${bindir}/diff ${D}${bindir}/diff.${PN}
22         mv ${D}${bindir}/cmp ${D}${bindir}/cmp.${PN}
23 }
24
25 ALTERNATIVE_NAME = "diff"
26 ALTERNATIVE_PATH = "diff.${PN}"
27 ALTERNATIVE_PRIORITY = "100"
28
29 pkg_postinst_${PN} () {
30
31 update-alternatives --install /usr/bin/cmp cmp cmp.diffutils 100
32
33 }
34
35 pkg_postrm_${PN} () {
36
37 update-alternatives --remove cmp cmp.diffutils
38
39 }