dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / device-mapper / device-mapper_1.02.28.bb
1 SECTION = "libs"
2 DESCRIPTION = "The Device-mapper is a new component of the linux kernel \
3 that supports logical volume management. It is required by LVM2 and EVMS. \
4 The original LVM (included in stock 2.4 kernels) does not use it."
5 LICENSE = "GPL"
6
7 S = "${WORKDIR}/${PN}.${PV}"
8
9 SRC_URI = "ftp://sources.redhat.com/pub/dm/device-mapper.${PV}.tgz \
10        file://devmap-mknod-busybox.patch;patch=1 \
11            file://remove_insanity.patch;patch=1 "
12
13 inherit autotools_stage update-rc.d
14 AUTOTOOLS_STAGE_PKGCONFIG = "1"
15
16 # The install-script will fail without this.
17 EXTRA_OECONF="--with-user= --with-group= "
18
19 INITSCRIPT_NAME = "devmap_mknod.sh"
20 INITSCRIPT_PARAMS = "defaults"
21
22 do_install_append() {
23         install -d ${D}/${libdir}/ioctl
24         install -m 755 ${S}/lib/ioctl/libdevmapper.a ${D}/${libdir}/ioctl/
25         install -D -m 755 ${S}/scripts/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
26 }
27
28 FILES_${PN}-dev += "${libdir}/ioctl/*.a"
29
30 do_stage_append() {
31         install -d ${STAGING_LIBDIR}/pkgconfig/
32         for pc in ${S}/*/*.pc ; do
33                 cp $pc ${STAGING_LIBDIR}/pkgconfig/
34                 cp $pc ${STAGING_LIBDIR}/pkgconfig/$(echo $(basename $pc) | sed s:lib::g)
35         done
36 }
37