Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / device-mapper / device-mapper_1.01.05.bb
1 SECTION = "libs"
2 DESCRIPTION = "The Device-mapper is a new component of the linux kernel \
3 that supports logical volume management. It is required by LVM2 and EVMS. \
4 The original LVM (included in stock 2.4 kernels) does not use it."
5 LICENSE = "GPL"
6 PR = "r4"
7
8 S = "${WORKDIR}/${PN}.${PV}"
9
10 SRC_URI = "ftp://sources.redhat.com/pub/dm/device-mapper.${PV}.tgz \
11            file://devmap-mknod-busybox.patch;patch=1 \
12            file://remove_insanity.patch;patch=1 "
13
14 inherit autotools update-rc.d
15
16 # The install-script will fail without this.
17 EXTRA_OECONF="--with-user= --with-group= "
18 TARGET_CC_ARCH += "${LDFLAGS}"
19
20
21 INITSCRIPT_NAME = "devmap_mknod.sh"
22 INITSCRIPT_PARAMS = "defaults"
23
24 do_stage () {
25         install -m 0644 ${S}/lib/libdevmapper.h ${STAGING_INCDIR} || die "failed to install libdevmapper.h"
26         oe_libinstall -a -so -C lib/ioctl libdevmapper ${STAGING_LIBDIR}
27 }
28
29 do_install() {
30         autotools_do_install
31 #       oe_runmake install_static_lib
32         install -d ${D}/${libdir}/ioctl
33         install -m 755 ${S}/lib/ioctl/libdevmapper.a ${D}/${libdir}/ioctl/
34         install -D -m 755 ${S}/scripts/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
35 }