increase dvbapp PR
[vuplus_openembedded] / recipes / dasher / dasher-gpe_0.0-svn.bb
1 LICENSE="GPL"
2 PV = "0.0+svnr${SRCPV}"
3 PR = "r1"
4 DEPENDS = "libxsettings-client libglade libxtst gconf gtk+"
5 SECTION = "gpe"
6 SRC_URI = "svn://svn.gnome.org/svn/dasher;module=trunk \
7         file://configure-lossage.patch;patch=1"
8
9 S = "${WORKDIR}/trunk"
10 FILES_${PN} += "${datadir}/dasher"
11
12 inherit autotools
13
14
15 EXTRA_OECONF = "--with-gpe --without-gnome --without-speech --without-a11y"
16 LDFLAGS_append = '-Wl,--export-dynamic'
17
18 do_configure_prepend() {
19         rm -f m4/libtool.m4
20         intltoolize --force
21 }
22
23 do_install_append () {
24         install -d ${D}${datadir}/pixmaps/
25         mv ${D}${datadir}/icons/dasher.png ${D}${datadir}/pixmaps/
26 }
27
28 python populate_packages_prepend () {
29         do_split_packages(d, bb.data.expand("${datadir}/dasher", d), "training_(.*).txt", "dasher-training-data-%s", "Dasher training data for %s", prepend=True)
30 }
31