increase dvbapp PR.
[vuplus_openembedded] / recipes / cyrus-sasl / cyrus-sasl_2.1.17.bb
1 SECTION = "console/network"
2 DEPENDS = "virtual/db"
3 DESCRIPTION = "Generic client/server library for SASL authentication."
4 LICENSE = "BSD"
5
6 PR = "r1"
7
8 SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/OLD-VERSIONS/sasl/cyrus-sasl-${PV}.tar.gz \
9            file://configure.patch;patch=1"
10
11 inherit autotools
12
13 acpaths = "-I ${S}/cmulocal -I ${S}/config -I ."
14 CFLAGS_append = " -I${S}/include -I${S}/saslauthd/include"
15 EXTRA_OECONF = "--enable-shared --enable-static --with-dblib=berkeley \
16                 --with-bdb-libdir=${STAGING_LIBDIR} \
17                 --with-bdb-incdir=${STAGING_INCDIR} \
18                 --without-opie --without-des"
19
20 do_configure_prepend () {
21         rm -f acinclude.m4 config/libtool.m4
22 }
23
24 do_compile_prepend () {
25         cd include
26         ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} makemd5.c -o makemd5
27         touch makemd5.o makemd5.lo makemd5
28         cd ..
29 }
30
31 do_stage () {
32         oe_libinstall -so -a -C lib libsasl2 ${STAGING_LIBDIR}
33         install -d ${STAGING_LIBDIR}/sasl
34         install -d ${STAGING_INCDIR}/sasl
35         install -m 0644 ${S}/include/hmac-md5.h ${STAGING_INCDIR}/sasl/
36         install -m 0644 ${S}/include/md5.h ${STAGING_INCDIR}/sasl/
37         install -m 0644 ${S}/include/md5global.h ${STAGING_INCDIR}/sasl/
38         install -m 0644 ${S}/include/sasl.h ${STAGING_INCDIR}/sasl/
39         install -m 0644 ${S}/include/saslplug.h ${STAGING_INCDIR}/sasl/
40         install -m 0644 ${S}/include/saslutil.h ${STAGING_INCDIR}/sasl/
41         install -m 0644 ${S}/include/prop.h ${STAGING_INCDIR}/sasl/
42 }