change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / custominput / custominput_1.1.0.bb
1 DESCRIPTION = "Custom Keyboard \
2 Keyboard that can be customized to include exactly the characters that the user uses, but which is not available on his physical keyboard."
3 SECTION = "opie/inputmethods"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 HOMEPAGE = "http://www.blackie.dk/Zaurus/custominput/"
7 AUTHOR = "Jesper Kjaer Pedersen <blackie@blackie.dk>"
8
9 SRC_URI = "http://www.blackie.dk/Zaurus/custominput/custominput-1.1.0.tgz"
10
11 inherit palmtop
12
13 QMAKE_PROFILES = "custominput.pro"
14
15 EXTRA_QMAKEVARS_POST += "DESTDIR=${S}"
16
17 do_configure_prepend() {
18         find ${S} -name Makefile|xargs rm
19 }
20
21 do_install() {
22
23         install -d ${D}${palmtopdir}/plugins/inputmethods/ \
24                            ${D}${palmtopdir}/pics/ \
25                            ${D}${palmtopdir}/bin/ \
26                            ${D}${palmtopdir}/apps/ \
27                            ${D}${palmtopdir}/apps/Settings/ \
28                            ${D}${palmtopdir}/help/html/
29
30         install -m 0755 ${S}/customInputConfig          ${D}${palmtopdir}/bin/
31         install -m 0644 ${S}/custominput.desktop        ${D}${palmtopdir}/apps/Settings/
32         install -m 0644 ${S}/customInputConfig.html ${D}${palmtopdir}/help/html/
33         install -m 0644 ${S}/custominput.png            ${D}${palmtopdir}/pics/
34         oe_libinstall -so -C ${S}/ libcustominput       ${D}${palmtopdir}/plugins/inputmethods/
35
36 }