increase dvbapp PR.
[vuplus_openembedded] / recipes / cups / cups_1.2.7.bb
1 DESCRIPTION = "An Internet printing system for Unix."
2 SECTION = "console/utils"
3 LICENSE = "GPL LGPL"
4 DEPENDS = "gnutls jpeg dbus dbus-glib libpng zlib fakeroot-native"
5 PR = "${INC_PR}.1"
6
7 SRC_URI = "ftp://ftp3.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2 \
8           "
9
10 inherit autotools binconfig
11
12 LDFLAGS += " -L${STAGING_LIBDIR} "
13
14 EXTRA_OECONF = " \
15                 --enable-gnutls \
16                 --enable-dbus \
17                 --enable-browsing \
18                 --disable-openssl \
19                 --disable-tiff \
20                 --without-php \
21                 --without-perl \
22                 --without-python \
23                 --without-java \
24                "
25
26
27 do_configure() {
28         gnu-configize
29         libtoolize --force
30         oe_runconf
31 }
32
33 do_compile () {
34         sed -i s:STRIP:NOSTRIP: Makedefs
35         sed -i s:serial:: backend/Makefile
36
37         echo "all:"    >  man/Makefile
38         echo "install:" >> man/Makefile
39
40         oe_runmake "SSLLIBS=-lgnutls -L${STAGING_LIBDIR}" \
41                    "LIBPNG=-lpng -lm -L${STAGING_LIBDIR}" \
42                    "LIBJPEG=-ljpeg -L${STAGING_LIBDIR}" \
43                    "LIBZ=-lz -L${STAGING_LIBDIR}" \
44                    "-I."
45 }
46
47 fakeroot do_install () {
48         oe_runmake "DSTROOT=${D}" install
49 }
50
51 do_stage () {
52         install -d ${STAGING_INCDIR}/cups
53         install ${S}/cups/*.h ${STAGING_INCDIR}/cups/
54         install ${S}/filter/*.h ${STAGING_INCDIR}/cups/
55         oe_libinstall -C cups -so libcups ${STAGING_LIBDIR}
56         oe_libinstall -C filter -so libcupsimage ${STAGING_LIBDIR}
57 }
58
59 FILES_${PN}-dbg += "${libdir}/cups/backend/.debug \
60                     ${libdir}/cups/cgi-bin/.debug \
61                     ${libdir}/cups/filter/.debug \
62                     ${libdir}/cups/monitor/.debug \
63                     ${libdir}/cups/notifier/.debug \
64                     ${libdir}/cups/daemon/.debug \
65                     "
66 #package the html for the webgui inside the main packages (~1MB uncompressed)
67
68 FILES_${PN} += "${datadir}/doc/cups/images \
69                 ${datadir}/doc/cups/*html \
70                 ${datadir}/doc/cups/*.css \
71                 ${datadir}/icons/ \
72                "
73
74
75
76