increase dvbapp PR.
[vuplus_openembedded] / recipes / crimsonfields / crimsonfields_0.4.8.bb
1 DESCRIPTION = "Crimson Fields is a tactical war game in the tradition of Battle Isle."
2 SECTION = "games"
3 DEPENDS = "crimsonfields-native virtual/libsdl libsdl-mixer libsdl-ttf"
4 LICENSE = "GPL"
5 PR = "r0"
6
7 SRC_URI = "http://crimson.seul.org/files/crimson-${PV}.tar.bz2 \
8            file://native-tools.patch;patch=1"
9 S = "${WORKDIR}/crimson-${PV}"
10
11 inherit autotools
12
13 HOST_TOOLS = "cfed mkdatafile mklocale mktileset mkunitset"
14
15 do_configure() {
16         gnu-configize
17         oe_runconf
18         for binary in ${HOST_TOOLS}
19         do
20                 install -m 0755 ${STAGING_BINDIR_NATIVE}/$binary tools/
21         done
22         install -m 0644 ${STAGING_DATADIR_NATIVE}/default.* tools/
23 }
24
25 do_install() {
26         autotools_do_install
27         install -d ${D}${palmtopdir}/apps/Games/
28         install -d ${D}${palmtopdir}/pics/
29         install -m 0644 ${D}${datadir}/applications/crimson.desktop ${D}${palmtopdir}/apps/Games/
30         install -m 0644 ${D}${datadir}/pixmaps/*.png ${D}${palmtopdir}/pics/
31 }
32
33 FILES_${PN} = "${bindir} ${datadir} ${palmtopdir}"