increase dvbapp PR.
[vuplus_openembedded] / recipes / corsair / corsair_0.2.6.bb
1 DESCRIPTION = "RSS aggregator for Qtopia"
2 SECTION = "opie/applications"
3 LICENSE = "GPL"
4 AUTHOR = "Joe Rumsey <joe@rumsey.org>"
5 HOMEPAGE = "http://corsair.sf.net/"
6 RDEPENDS = "opie-pics"
7
8 PR = "r1"
9
10 inherit palmtop
11
12 SRC_URI = "${SOURCEFORGE_MIRROR}/corsair/corsair-${PV}.tar.gz \
13            file://corsair-opie.patch;patch=1"
14
15 S = "${WORKDIR}/corsair"
16
17 do_configure() {
18 }
19
20 do_compile() {
21         oe_runmake LIBS="-l${QT_LIBRARY} -lqpe"
22 }
23
24 do_install() {
25         install -d ${D}${palmtopdir}/pics/
26         install -d ${D}${palmtopdir}/apps/Applications/
27         install -d ${D}${palmtopdir}/bin
28         install -m 0644 ${S}/Corsair.png ${D}${palmtopdir}/pics/
29         install -m 0644 ${S}/corsair.desktop ${D}${palmtopdir}/apps/Applications/
30         install -m 0644 ${S}/icons/newfeed.png ${S}/icons/get.png ${D}${palmtopdir}/pics/
31         install -m 0755 ${S}/corsair ${D}${palmtopdir}/bin/
32 }