enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / compcache / compcache_0.5+0.6pre3.bb
1 HOMEPAGE = "http://code.google.com/p/compcache"
2 DESCRIPTION = "Kernel drivers version 0.6x and related tool for the compcache (compressed in-memory swap device for linux)"
3 LICENSE = "GPLv2"
4
5 inherit module
6
7 SRC_URI = "http://compcache.googlecode.com/files/${PN}-0.6pre3.tar.gz \
8         file://000-compcache-KERNELDIR.patch;patch=1 \
9         file://001-compcache-rzscontrol-cross-compile.patch;patch=1 \
10         file://002-compcache-modules-install.patch;patch=1 \
11            "
12 S = "${WORKDIR}/${PN}-0.6pre3"
13
14 TARGET_CC_ARCH += "${LDFLAGS}"
15
16 PACKAGES = "kernel-module-compcache compcache-utils compcache-utils-dbg compcache-utils-doc"
17
18 FILES_kernel-module-compcache = ${FILES_compcache}
19 FILES_compcache-utils = "${bindir}/rzscontrol"
20 FILES_compcache-utils-dbg = "${bindir}/.debug/rzscontrol"
21 FILES_compcache-utils-doc = "${mandir}/man1/rzscontrol.1"
22
23 do_install_prepend() {
24         mkdir -p ${D}${bindir}
25         mkdir -p ${D}${mandir}/man1
26         install -m 0755 ${S}/sub-projects/rzscontrol/rzscontrol ${D}${bindir}
27         install -m 0644 ${S}/sub-projects/rzscontrol/man/rzscontrol.1 ${D}${mandir}/man1
28 }
29