increase dvbapp PR
[vuplus_openembedded] / recipes / cdstatus / cdstatus_0.97.01.bb
1 # cdstatus OE build file
2
3 PR ="r0"
4 LICENSE="GPL"
5 HOMEPAGE = "http://cdstatus.sourceforge.net/"
6 FILES_${PN} += "${datadir}/cdstatus.cfg"
7 # need __USE_MISC to get h_addr macro in netdb.h
8 CFLAGS += -D__USE_MISC
9
10 SRC_URI="${SOURCEFORGE_MIRROR}/cdstatus/cdstatus-0.97.01.tar.gz \
11          file://Makefile.am.patch;patch=1 \
12          file://cddb_connect_to_server.c.patch;patch=1 \
13          file://cdstatus.patch;patch=1"
14
15 S="${WORKDIR}/cdstatus-0.97.01"
16
17 inherit autotools
18
19 do_install() {
20         install -d 0755 ${D}/${bindir}
21         install -d 0755 ${D}/${datadir}
22         install -d 0755 ${D}/${mandir}
23         install -m 0755 src/cdstatus          ${D}/${bindir}
24         install -m 0644 cdstatus.cfg          ${D}/${datadir}
25         install -m 0644 cdstatus.1            ${D}/${mandir}
26
27 }