increase dvbapp PR.
[vuplus_openembedded] / recipes / bzip2 / bzip2_1.0.5.bb
1 DESCRIPTION = "Very high-quality data compression program"
2 SECTION = "console/utils"
3 PR = "r2"
4
5 LICENSE = "bzip2"
6 SRC_URI = "http://www.bzip.org/${PV}/bzip2-${PV}.tar.gz \
7            file://bzip2-1.0.5-autoconfiscated.patch;patch=1"
8
9 inherit autotools pkgconfig
10
11 do_configure_prepend () {
12         if test -f LICENSE ; then sh ./autogen.sh ; fi
13 }
14
15 do_install_append () {
16         mv ${D}${bindir}/bunzip2 ${D}${bindir}/bunzip2.${PN}
17         mv ${D}${bindir}/bzcat ${D}${bindir}/bzcat.${PN}
18         ln -sf libbz2.so.1.0.5 ${D}${libdir}/libbz2.so.1.0
19 }
20
21 PACKAGES =+ "libbz2"
22 FILES_libbz2 = "${libdir}/libbz2.so.*"
23
24 pkg_postinst_${PN} () {
25         update-alternatives --install ${bindir}/bunzip2 bunzip2 bunzip2.${PN} 100
26         update-alternatives --install ${bindir}/bzcat bzcat bzcat.${PN} 100
27 }
28
29 pkg_prerm_${PN} () {
30         update-alternatives --remove bunzip2 bunzip2.${PN}
31         update-alternatives --remove bzcat bzcat.${PN}
32 }