increase dvbapp PR.
[vuplus_openembedded] / recipes / brutefir / brutefir_1.0i.bb
1 DESCRIPTION = "BruteFIR is a software convolution engine, a program for applying long FIR filters to multi-channel digital audio, either offline or in realtime."
2 LICENSE = "GPLv2"
3
4 DEPENDS = "alsa-lib fftw fftwf fftwl"
5
6 PR = "r1"
7
8 # The unbreak-makefile disables the SSE2, MMX and jack support, feel free 
9 # to add back SSE and MMX after fixing the makefile to not use uname to check for cpu 
10
11 SRC_URI = "http://www.ludd.luth.se/~torger/files/brutefir-${PV}.tar.gz \
12            file://unbreak-makefile.patch;patch=1 \
13            "
14
15 do_configure() {
16        sed -i -e s:-L/usr/local/lib:-L${STAGING_LIBDIR}:g Makefile
17        sed -i -e s:-I/usr/local/include:-I${STAGING_INCDIR}:g Makefile
18 }
19
20 do_install() {
21         install -d ${D}${bindir}
22         install -m 755 *.bf* ${D}${bindir}
23         install -m 755 brutefir ${D}${bindir}
24 }
25