rename packages/ to recipes/ per earlier agreement
[vuplus_openembedded] / recipes / bootsplash / bootsplash_3.0.7.bb
1 # bootsplash OE build file
2 # Copyright (C) 2004, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 DESCRIPTION="Bootsplash shows pretty pictures during boot"
6 HOMEPAGE="http://www.bootsplash.org"
7 SECTION = "media-gfx"
8 LICENSE = "GPL"
9 SRC_URI="ftp://ftp.openbios.org/pub/bootsplash/rpm-sources/bootsplash/bootsplash-${PV}.tar.bz2 \
10          file://freetype2.patch;patch=1 \
11          file://gcc-issues.patch;patch=1"
12
13 DEPENDS="freetype libmng"
14 PR = "r1"
15
16 EXTRA_OEMAKE += "-C Utilities \
17                 CFLAGS='${CFLAGS} -I${STAGING_INCDIR}/freetype2/ -I${STAGING_INCDIR}' \
18                 LDFLAGS='${LDFLAGS} -L${STAGING_LIBDIR} -ljpeg'"
19
20 do_compile() {
21         oe_runmake
22 }
23
24 do_install() {
25         install -d ${D}${bindir}/
26         install -m 0755 ${S}/Utilities/fbtruetype ${D}${bindir}
27         install -m 0755 ${S}/Utilities/splash ${D}${bindir}
28 }