increase dvbapp PR.
[vuplus_openembedded] / recipes / boost-asio / boost-asio_0.3.7.bb
1 DESCRIPTION = "Asio 0.3.7 for work with boost, should be moved into boost package once integrated into the boost distribution."
2 HOMEPAGE = "http://asio.sf.net/"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "Boost Software License"
6 PR = "r2"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/asio/boost_asio_0_3_7.tar.bz2"
9
10 # mtx-[12] use 2.4 kernels but the kernel-libc-headers are from kernel 2.6,
11 # thus the automatic epoll detection does not work in epoll_reactor_fwd.hpp.
12 SRC_URI_append_mtx-1 = " file://disable-epoll.patch;patch=1"
13 SRC_URI_append_mtx-2 = " file://disable-epoll.patch;patch=1"
14
15 S = "${WORKDIR}/boost_asio_0_3_7"
16
17 do_configure() {
18 }
19
20 do_compile() {
21 }
22
23 do_install() {
24         cd ${S}
25         install -d ${D}/usr/include
26         cp -dpR boost ${D}/usr/include
27 }
28
29 do_stage() {
30         cd ${S}
31         install -d -m 775 ${STAGING_INCDIR}
32         cp -dpR boost ${STAGING_INCDIR}
33 }
34
35 FILES_${PN}-dev = "/usr/include"