increase dvbapp PR.
[vuplus_openembedded] / recipes / bochs / bochs_2.1.bb
1 DESCRIPTION = "An x86 Emulator based on SDL."
2 HOMEPAGE = "http://bochs.sf.net"
3 LICENSE = "GPL"
4 PR = "r1"
5
6 # needs a patch for recent g++
7 BROKEN = "1"
8
9 APPIMAGE = "doc/docbook/images/dlxlinux-in-linux.png"
10
11 SRC_URI = "${SOURCEFORGE_MIRROR}/bochs/bochs-${PV}.tar.gz \
12            file://compile.patch;patch=1"
13
14 inherit autotools sdl
15
16 EXTRA_OECONF = "--without-x                 \
17                 --without-x11               \
18                 --without-beos              \
19                 --without-win32             \
20                 --without-macos             \
21                 --without-carbon            \
22                 --without-nogui             \
23                 --without-term              \
24                 --without-rfb               \
25                 --without-amigaos           \
26                 --with-sdl                  \
27                 --without-svga              \
28                 --without-wx"
29
30 do_compile() {
31         oe_runmake bochs bximage bxcommit
32 }
33
34 do_install() {
35         oe_runmake -i install # yes, ugly i know... but i can't get rid of that bailing out docbook crap atm.
36 }