bluez-gnome: Update to version 1.8.
[vuplus_openembedded] / recipes / bluez / bluez4_4.37.bb
1 DESCRIPTION = "Linux Bluetooth Stack Userland V4"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
5 HOMEPAGE = "http://www.bluez.org"
6 LICENSE = "GPL"
7
8 # For angstrom we want this to replace at least bluez-libs
9 PROVIDES_append_angstrom = " bluez-utils bluez-libs"
10
11 SRC_URI = "\
12   http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
13   file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
14   file://sbc-thumb.patch;patch=1 \
15   file://bluetooth.conf \
16 "
17 S = "${WORKDIR}/bluez-${PV}"
18
19 inherit autotools_stage
20 AUTOTOOLS_STAGE_PKGCONFIG = "1"
21
22 EXTRA_OECONF = "\
23   --enable-gstreamer \
24   --enable-alsa \
25   --enable-usb \
26   --enable-netlink \
27   --enable-tools \
28   --enable-bccmd \
29   --enable-hid2hci \
30   --enable-dfutool \
31   --enable-hidd \
32   --enable-pandd \
33   --enable-dund \
34   --disable-cups \
35   --enable-test \
36   --enable-manpages \
37   --enable-configfiles \
38   --enable-initscripts \
39   --disable-pcmciarules \
40 "
41
42 do_install_append() {
43         install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
44         install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
45         install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
46         # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
47         install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
48 }
49
50 PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
51
52 FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
53 FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
54 FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
55 FILES_${PN}-dev += "\
56   ${libdir}/bluetooth/plugins/*.la \
57   ${libdir}/alsa-lib/*.la \
58   ${libdir}/gstreamer-0.10/*.la \
59 "
60
61 FILES_${PN}-dbg += "\
62   ${libdir}/bluetooth/plugins/.debug \
63   ${libdir}/*/.debug \
64 "