bluez-gnome: Update to version 1.8.
[vuplus_openembedded] / recipes / bluez / bluez4_4.35.bb
1 DESCRIPTION = "Linux Bluetooth Stack Userland V4"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
5 HOMEPAGE = "http://www.bluez.org"
6 LICENSE = "GPL"
7
8 # For angstrom we want this to replace at least bluez-libs
9 PROVIDES_append_angstrom = " bluez-utils bluez-libs"
10
11
12 PR = "r1"
13
14 SRC_URI = "\
15   http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
16   file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
17   file://sbc-thumb.patch;patch=1 \
18   file://bluetooth.conf \
19 "
20 S = "${WORKDIR}/bluez-${PV}"
21
22 inherit autotools_stage
23 AUTOTOOLS_STAGE_PKGCONFIG = "1"
24
25 EXTRA_OECONF = "\
26   --enable-gstreamer \
27   --enable-alsa \
28   --enable-usb \
29   --enable-netlink \
30   --enable-tools \
31   --enable-bccmd \
32   --enable-hid2hci \
33   --enable-dfutool \
34   --enable-hidd \
35   --enable-pandd \
36   --enable-dund \
37   --disable-cups \
38   --enable-test \
39   --enable-manpages \
40   --enable-configfiles \
41   --enable-initscripts \
42   --disable-pcmciarules \
43 "
44
45 do_install_append() {
46         install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
47         install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
48         install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
49         # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
50         install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
51 }
52
53 PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
54
55 FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
56 FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
57 FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
58 FILES_${PN}-dev += "\
59   ${libdir}/bluetooth/plugins/*.la \
60   ${libdir}/alsa-lib/*.la \
61   ${libdir}/gstreamer-0.10/*.la \
62 "
63
64 FILES_${PN}-dbg += "\
65   ${libdir}/bluetooth/plugins/.debug \
66   ${libdir}/*/.debug \
67 "