bluez-gnome: Update to version 1.8.
[vuplus_openembedded] / recipes / bluez / bluez4_4.31.bb
1 DESCRIPTION = "Linux Bluetooth Stack Userland V4"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
5 HOMEPAGE = "http://www.bluez.org"
6 LICENSE = "GPL"
7 PR = "r6"
8
9 SRC_URI = "\
10   http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
11   file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
12   file://sbc-thumb.patch;patch=1 \
13   file://bluetooth.conf \
14 #  file://hid2hci_usb_init.patch;patch=1 \
15 "
16 S = "${WORKDIR}/bluez-${PV}"
17
18 inherit autotools pkgconfig
19
20 OE_LT_RPATH_ALLOW = "any"
21 OE_LT_RPATH_ALLOW[export] = "1"
22
23 EXTRA_OECONF = "\
24   --enable-gstreamer \
25   --enable-alsa \
26   --enable-usb \
27   --enable-netlink \
28   --enable-tools \
29   --enable-bccmd \
30   --enable-hid2hci \
31   --enable-dfutool \
32   --enable-hidd \
33   --enable-pandd \
34   --enable-dund \
35   --disable-cups \
36   --enable-test \
37   --enable-manpages \
38   --enable-configfiles \
39   --enable-initscripts \
40   --disable-pcmciarules \
41 "
42
43 do_install_append() {
44         install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
45         install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
46         install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
47         # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
48         install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
49 }
50
51 PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
52
53 FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
54 FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
55 FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
56 FILES_${PN}-dev += "\
57   ${libdir}/bluetooth/plugins/*.la \
58   ${libdir}/alsa-lib/*.la \
59   ${libdir}/gstreamer-0.10/*.la \
60 "
61 FILES_${PN}-dbg += "\
62   ${libdir}/bluetooth/plugins/.debug \
63   ${libdir}/*/.debug \
64 "