Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / recipes / bluez / bluez-utils_3.36.bb
1 require bluez-utils3.inc
2
3 PR = "r4"
4
5 # removed hciattach-ti-bts.patch (landed upstream)
6 SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
7            file://hcid.conf \
8            file://sbc-thumb.patch;patch=1"
9
10 # see bluez-utils3.inc for the explanation of these option
11 EXTRA_OECONF = " \
12                  --enable-bccmd \
13                  --enable-hid2hci \
14                  --enable-hidd \
15                  --enable-pand \
16                  --enable-dund \
17                  --disable-alsa \ 
18                  --disable-cups \
19                  --enable-glib \
20                  --disable-sdpd \
21                  --enable-network \
22                  --enable-serial \
23                  --enable-input \
24                  --enable-audio \
25                  --enable-echo \
26                  --enable-configfile \
27                  --enable-initscripts \
28                 --enable-test \
29                 --enable-hidd \
30                 --enable-obex \
31                 --enable-pand \
32                 --enable-dund \
33                 --enable-avctrl \
34                 --enable-hid2hci \
35                 --enable-dfutool \
36
37
38 CONFFILES_${PN} = " \
39                    ${sysconfdir}/bluetooth/hcid.conf \
40                    ${sysconfdir}/default/bluetooth \
41                   "
42
43 CONFFILES_${PN}-compat = " \
44                           ${sysconfdir}/bluetooth/rfcomm.conf \
45                          "
46
47 PACKAGES =+ "bluez-audio"
48
49 FILES_${PN} = " \
50                ${base_sbindir}/hcid \
51                ${libdir}/bluetooth/plugins/*.so \
52                ${sysconfdir}/init.d/bluetooth \
53                ${sysconfdir}/bluetooth/hcid.conf \
54                ${sysconfdir}/default \
55                ${sysconfdir}/dbus-1 \
56                ${base_sbindir}/hciattach \
57               "
58
59 FILES_bluez-audio = " \
60                      ${libdir}/bluetooth/plugins/libaudio.so \
61                      ${libdir}/gstreamer-0.10/*.so \
62                     "
63
64 FILES_${PN}-dbg += " \
65                     ${libdir}/bluetooth/plugins/.debug \
66                     ${libdir}/gstreamer-0.10/.debug \
67                    "
68
69 FILES_${PN}-dev += " \
70                     ${libdir}/bluetooth/plugins/*.la \
71                     ${libdir}/gstreamer-0.10/*.la \
72                    "