fix included modules.
[vuplus_openembedded] / recipes / blueman / blueman_1.10.bb
1 DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager"
2 HOMEPAGE = "http://www.blueman-project.org/"
3 SECTION = "optional"
4 DEPENDS = "gtk+ glib-2.0 bluez4 intltool python python-native python-pyrex startup-notification"
5 RDEPENDS = "python-dbus python-pygobject python dbus bluez4 python-pygtk python-notify obex-data-server \
6 "
7
8 PR = "r1"
9
10 inherit autotools pkgconfig
11
12 EXTRA_OECONF += "--with-no-runtime-deps-check"
13
14 BLUEZ_LIBS = "-L${libdir} -lbluetooth"
15 BLUEZ_CFLAGS = "-I${includedir}"
16
17 SRC_URI = "\
18         http://download.tuxfamily.org/blueman/blueman-${PV}.tar.gz\
19         "
20
21 FILES_${PN}-dbg += "${libdir}/python2.6/site-packages/.debug"
22 FILES_${PN} += "${libdir} ${datadir}"
23
24 do_configure_prepend() {
25                 sed -i "s/py_prefix=.*$/py_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
26                 sed -i "s/py_exec_prefix=.*$/py_exec_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
27 }