dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / binutils / binutils_2.17.bb
1 require binutils.inc
2 require binutils-avr32.inc
3
4 INC_PR = "r7"
5 PR = "${INC_PR}.1"
6
7 SRC_URI = \
8     "http://ftp.gnu.org/gnu/binutils/binutils-${PV}.tar.bz2 \
9      file://better_file_error.patch;patch=1 \
10      file://signed_char_fix.patch;patch=1 \
11 "
12
13 #patches from http://svn.uclibc.org/cgi-bin/viewcvs.cgi/trunk/buildroot/toolchain/binutils/2.17/
14
15 SRC_URI += "\
16         file://100-uclibc-conf.patch;patch=1 \
17         file://300-006_better_file_error.patch;patch=1 \
18         file://702-binutils-skip-comments.patch;patch=1 \
19         file://110-arm-eabi-conf.patch;patch=1 \
20         file://300-012_check_ldrunpath_length.patch;patch=1 \
21         file://300-001_ld_makefile_patch.patch;patch=1 \
22         file://400-mips-ELF_MAXPAGESIZE-4K.patch;patch=1 \
23 "
24 # removed in favor of the atmel 1.2.6 patch which is supposedly newer (yes)
25 #        file://500-avr32-atmel.1.3.0.patch;patch=1 \
26 #        file://501-avr32-fix-pool-alignment.patch;patch=1 \
27
28 SRC_URI_append_avr32 = "\
29         file://binutils-2.17.atmel.1.2.6.patch.bz2;patch=1 \
30 "
31
32 # Zecke's OSX fixes
33 SRC_URI += " file://warning-free.patch;patch=1 "