increase dvbapp PR.
[vuplus_openembedded] / recipes / beep / beep_1.2.2.bb
1 # beep: a console utility to "and allow a little more granularity
2 # than you get with the default terminal bell"
3 DESCRIPTION = "A console utility to make a beep noise"
4 SECTION = "console/utils"
5 LICENSE = "GPL"
6 PR = "r2"
7
8 SRC_URI  = "http://johnath.com/beep/beep-${PV}.tar.gz"
9 SRC_URI += "file://linux-input.patch;patch=1"
10
11 S = "${WORKDIR}/beep-${PV}"
12 PACKAGES += "${PN} ${PN}-doc"
13
14 inherit autotools
15
16 EXTRA_OEMAKE += 'CC="${CC}"'
17 EXTRA_OEMAKE += 'FLAGS="${CFLAGS}"'
18
19 # slugos requires beep in boot
20 BINDIR = "${bindir}"
21 BINDIR_slugos = "${base_bindir}"
22
23 do_install() {
24         # this is easier than patching the Makefile...
25         install -d "${D}${BINDIR}"
26         install -c -m 755 beep "${D}${BINDIR}/beep"
27         install -d "${D}${mandir}/man1"
28         install -c -m 644 beep.1.gz "${D}${mandir}/man1/beep.1.gz"
29 }