Merge branch 'opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / balsa / balsa_2.4.2.bb
1 DESCRIPTION = "Robust and configurable e-mail client for GNOME"
2 HOMEPAGE = "http://pawsa.fedorapeople.org/balsa/"
3 SECTION = "x11/network"
4 LICENSE = "GPL"
5 SRC_URI = "http://pawsa.fedorapeople.org/balsa/${P}.tar.bz2 \
6            file://libbalsa-gpe-corruption.patch;patch=1"
7 PR = "r1"
8
9 DEPENDS = "glib-2.0 gmime gnome-icon-theme gtk+ intltool-native libesmtp libxml-parser-perl-native"
10 RDEPENDS_${PN} = "gnome-icon-theme"
11 # FIXME: It is possible to build several variants of balsa: lite (SSL, gqlite/GPE, maybe HTML),
12 # standard (GNOME, spell checking, HTML), full (Kerberos, LDAP, PGP, Rubrica, X-Face)
13
14 # Options for regular expressions are: NONE (POSIX) glib-2.0 (GRegex) libpcre (PCRE)
15 DEPENDS += ""
16
17 # Options for remote activation are: libbonobo libunique
18 DEPENDS += "libunique"
19
20 # Options for HTML view are: gtkhtml-2.0 gtkhtml-3.0 webkit-gtk NONE
21 DEPENDS += "webkit-gtk"
22
23 # Optional dependencies (missing in OE): Spell checking
24 #DEPENDS += "gtkspell"
25
26 # Optional dependencies: desktop notification:
27 DEPENDS += "libnotify"
28
29 # Optional dependencies: SSL support:
30 DEPENDS += "openssl"
31
32 # Optional dependencies: GPE addressbook:
33 DEPENDS += "sqlite"
34
35 # Optional dependencies: GNOME:
36 DEPENDS += "gconf libgnome libgnomeui"
37 #DEPENDS += "gnome-keyring"
38
39 # Optional dependencies: PGP support:
40 #DEPENDS += "gpgme"
41
42 # Optional dependencies: view source:
43 #DEPENDS += "gtksourceview2"
44
45 # Optional dependencies: LDAP:
46 #DEPENDS += "openldap"
47
48 # Options for optional Kerberos 5: heimdal (not in OE) krb5
49 #DEPENDS += "krb5"
50
51 # Optional dependencies: automatic online/offline with NetworkManager:
52 #DEPENDS += "networkmanager"
53
54 # Optional dependencies: Rubrica addressbook:
55 #DEPENDS += "libxml2"
56
57 # Optional dependencies (not yet in OE): X-Face support:
58 #DEPENDS += "compface"
59
60 # Optional dependencies: sound support:
61 #DEPENDS += "libcanberra"
62
63 # FIXME: doc build requires docbook4 and gnome-doc-utils
64
65 inherit autotools gtk-icon-cache
66
67 EXTRA_OECONF="--with-ssl \
68               --without-gnome \
69               --disable-scrollkeeper \
70               --enable-smime \
71               --with-sqlite \
72               --with-ssl \
73               --with-webkit \
74               --with-unique \
75               --without-gtkspell \
76               --without-nm \
77 "
78 # Broken (does not compile, crashes after symbol fix):
79 #             --enable-touch-ui \
80 # Not enabled:
81 #             --with-gtkspell \
82 #             --with-gpgme \
83 #             --with-gtksourceview \
84 #             --with-rubrica \
85 #             --with-gss \
86 #             --with-ldap \
87 #             --with-compface \
88 #             --with-canberra \
89
90 do_configure_prepend() {
91         # aclocal seems to insist on looking in here.  Make sure it exists.
92         mkdir -p ${S}/m4
93 }