increase dvbapp PR.
[vuplus_openembedded] / recipes / at91bootstrap / at91bootstrap_2.4.bb
1 require at91bootstrap.inc
2 SRC_URI = "ftp://www.at91.com/pub/buildroot/${PN}-${PV}.tar.bz2 \
3            "
4 SRC_URI_append_afeb9260 = " file://0001-Generic-code-changes.patch;patch=1 \
5            file://0002-Making-image-directly-flashable.patch;patch=1 \
6            file://0003-AFEB9260-board-support.patch;patch=1 \
7            file://0004-AFEB9260-133-board-support.patch;patch=1"
8
9 PR = "r5"
10
11 AT91BOOTSTRAP_MACHINE ?= "${MACHINE}"
12 AT91BOOTSTRAP_FLAGS ?= ""
13 AT91BOOTSTRAP_MEMORY ?= "dataflash"
14
15 AT91BOOTSTRAP_IMAGE = "at91bootstrap-${MACHINE}-${AT91BOOTSTRAP_MEMORY}-${PV}-${PR}.bin"
16 AT91BOOTSTRAP_SYMLINK = "at91bootstrap.bin"
17
18 PACKAGE_ARCH = "${MACHINE_ARCH}"
19 EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} MEMORY=${AT91BOOTSTRAP_MEMORY}"
20
21 do_compile () {
22         unset LDFLAGS
23         unset CFLAGS
24         unset CPPFLAGS
25
26         rm -Rf ${S}/binaries
27         oe_runmake ${AT91BOOTSTRAP_MACHINE}_defconfig
28         oe_runmake AT91_CUSTOM_FLAGS="${AT91BOOTSTRAP_FLAGS}"
29         chmod +x ${S}/fixboot.py
30         ${S}/fixboot.py ${S}/binaries/${AT91BOOTSTRAP_MACHINE}-${AT91BOOTSTRAP_MEMORY}boot-${PV}.bin
31 }
32
33 do_deploy () {
34         install -d ${DEPLOY_DIR_IMAGE}
35         install ${S}/binaries/${AT91BOOTSTRAP_MACHINE}-${AT91BOOTSTRAP_MEMORY}boot-${PV}.bin.fixboot \
36                 ${DEPLOY_DIR_IMAGE}/${AT91BOOTSTRAP_IMAGE}
37         package_stagefile_shell ${DEPLOY_DIR_IMAGE}/${AT91BOOTSTRAP_IMAGE}
38         cd ${DEPLOY_DIR_IMAGE}
39         rm -f ${AT91BOOTSTRAP_SYMLINK}
40         ln -sf ${AT91BOOTSTRAP_IMAGE} ${AT91BOOTSTRAP_SYMLINK}
41         package_stagefile_shell ${DEPLOY_DIR_IMAGE}/${AT91BOOTSTRAP_SYMLINK}
42 }
43
44 do_deploy[dirs] = "${S}"
45 addtask deploy before do_build after do_compile