increase dvbapp PR.
[vuplus_openembedded] / recipes / asleap / asleap_2.1.bb
1 SECTION = "console/network"
2 DESCRIPTION = "Proof of concept Cisco Leap Cracker"
3 HOMEPAGE = "http://asleap.sourceforge.net - outdated"
4 LICENSE = "GPLv2"
5 DEPENDS = "libpcap openssl"
6
7 SRC_URI = "http://802.11ninja.net/~jwright/code/${PN}-${PV}.tgz \
8            file://if.h.patch;patch=1 \
9            "
10
11 S = "${WORKDIR}/${PN}-${PV}"
12
13 CFLAGS_append = " -D_LINUX -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
14                   -D_OPENSSL_MD4 -L${STAGING_LIBDIR}"
15
16 do_install() {
17         install -d ${D}/${sbindir}
18         install -m 0755 asleap       ${D}/${sbindir}
19         install -d ${D}/${bindir}
20         install -m 0755 genkeys      ${D}/${bindir}
21 }
22
23 #
24 # Maintainer's note: I am currently not including the test dump file or the
25 # scripts directory due to size constraints and the fact that it seems
26 # pointless.  If someone requests it, I might add it as a seperate package.
27 #