dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / arpwatch / arpwatch_2.1a15.bb
1 DESCRIPTION = "Ethernet/FDDI station activity monitor"
2 HOMEPAGE = "http://www-nrg.ee.lbl.gov/"
3 SECTION = "network"
4 LICENSE = "BSD"
5 RRECOMMENDS = "arpwatch-data"
6 PR = "r2"
7
8 SRC_URI = "ftp://ftp.ee.lbl.gov/arpwatch-${PV}.tar.gz \
9            file://05debian_fhs.patch;patch=1 \
10            file://06debian_manpages.patch;patch=1 \
11            file://init.d \
12            file://arpwatch.default \
13            file://arpwatch.conf \
14            file://ethercodes.dat \
15            file://make.patch;patch=1 \
16            file://volatiles.08_arpwatch"
17
18 inherit autotools update-rc.d
19
20 PACKAGES =+ "arpwatch-data"
21
22 FILES_arpwatch-data = "${datadir}/arpwatch/ethercodes.dat"
23
24 fakeroot do_install() {
25         install -d ${D}${bindir} ${D}${sbindir} ${D}${mandir}/man8 \
26                 ${D}${sysconfdir}/default \
27                 ${D}${sysconfdir}/init.d \
28                 ${D}${datadir}/arpwatch \
29                 ${D}${sysconfdir}/default/volatiles
30         oe_runmake install DESTDIR=${D}
31         oe_runmake install-man DESTDIR=${D}
32         for i in arp2ethers arpfetch massagevendor; do
33           install -m 0755 ${S}/$i ${D}${sbindir}
34         done
35         install -m 0755 ${S}/bihourly.sh ${D}${sbindir}/bihourly
36         for i in arp2ethers arpfetch bihourly massagevendor; do
37           install -m 0644 ${S}/$i.8 ${D}${mandir}/man8
38         done
39         install -m 0755 ${WORKDIR}/init.d ${D}${sysconfdir}/init.d/arpwatch
40         install -m 0644 ${WORKDIR}/arpwatch.default ${D}${sysconfdir}/default/arpwatch
41         install -m 0644 ${WORKDIR}/arpwatch.conf ${D}${sysconfdir}
42         install -m 0644 ${WORKDIR}/ethercodes.dat ${D}${datadir}/arpwatch
43
44         # We need some /var directories
45         for i in 08_arpwatch; do
46           install -m 0644 ${WORKDIR}/volatiles.$i ${D}${sysconfdir}/default/volatiles/$i
47         done
48 }
49
50 pkg_postinst_${PN} () {
51         /etc/init.d/populate-volatile.sh update
52 }
53
54 CONFFILES_${PN} = "${sysconfdir}/default/arpwatch \
55                    ${sysconfdir}/arpwatch.conf"
56
57 INITSCRIPT_NAME = "arpwatch"
58 INITSCRIPT_PARAMS = "defaults 95 05"