change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / appweb / appweb_2.0.4.bb
1 DESCRIPTION = "AppWeb is an embedded HTTP Web server that has been designed with security in mind."
2 SECTION = "console/network"
3 LICENSE = "GPL"
4 SRC_URI = "http://www.mbedthis.com/software/appWeb-src-${PV}-1.tar.gz \
5            file://makerules.patch;patch=1 \
6            file://init.d.patch;patch=1 \
7            file://libdb.patch;patch=1"
8 S = "${WORKDIR}/appWeb-${PV}"
9
10 APPWEB_HOST = "${@get_appweb_host(d, bb)}"
11 APPWEB_BUILD = "${BUILD_SYS}"
12
13 require appweb.inc
14
15 #  --buildNumber=NUMBER     Set the build number part of the version (1.0.0.X).
16 #  --name=NAME              Set the full product name (BLD_NAME define).
17 #  --port=PORT              Set the default HTTP port to use for the product.
18 #  --product=NAME           Set the one word (no spaces) name of the product.
19 #  --setLibVersion=X.X.X    Set the shared library version number.
20 #  --setVersion=X.X.X       Set the product version number.
21 #  --sslPort=PORT           Set the default SSL port to use for the product.
22 #  --type=BUILD             Set the build type (DEBUG|RELEASE).
23 #
24 #  --enable-access-log      Enable logging of requests to the AppWeb access log.
25 #  --enable-assert          Build with assert checking.
26 #  --enable-config          Build with the ability to parse Apache-style config
27 #  --enable-cookie          Build with cookie handling support.
28 #  --enable-digest-auth     Build with digest authentication support.
29 #  --enable-fast-malloc     Build with the Mbedthis fast malloc.
30 #  --enable-if-modified     Build with HTTP If-Modified checking.
31 #  --enable-keep-alive      Build with HTTP Keep-Alive support.
32 #  --enable-log             Build with the AppWeb trace log facility.
33 #  --enable-modules         Build with the dynamically loaded modules capability.
34 #  --enable-multi-thread    Build AppWeb multi-threaded.
35 #  --disable-multi-thread   Build AppWeb single threaded.
36 #  --enable-rom-fs          Build with the ability to load web pages from ROM.
37 #  --enable-run-as-service  Build with the ability to run as a service/daemon.
38 #  --disable-run-as-service Do not include the ability to run as a service.
39 #  --enable-safe-strings    Enforce safe string handling.
40 #  --enable-session         Build with HTTP session support.
41 #  --enable-shared          Build an appWeb shared library and program. [default]
42 #  --enable-shared-libc     Link with the shared versions of libc.
43 #  --disable-shared-libc    Link with the static versions of libc.
44 #  --enable-squeeze         Build in squeeze mode for minimal memory footprint.
45 #  --disable-squeeze        Build for speed.
46 #  --enable-static          Build a static appWeb library and program. [default]
47 #  --disable-static         Do not build a static appWeb library and program.
48 #
49 #  --with-admin             Include the admin handler.
50 #  --with-auth              Include the authorization handler.
51 #  --with-c_api             Include the C API.
52 #  --with-cgi               Include the CGI handler.
53 #  --with-gacompat          Include GoAhead WebServer API compatibility.
54 #  --with-copy              Build support for the copy handler.
55 #  --with-egi               Include the EGI handler.
56 #  --with-esp               Include the ESP handler.
57 #  --with-ssl               Build support for the SSL protocol.
58 #  --with-upload            Build with the file upload handler
59 #  --with-xdb               Build with XDB
60 #  Supported PACKAGE names: openssl, php4, php5
61 #  --with-PACKAGE=[builtin|, module]
62 #                           Include support for the PACKAGE. Link into appWeb
63 #                           statically and/or build as a module
64 #  --with-PACKAGE-dir=DIR   Set the source directory of the package
65 #  --with-PACKAGE-libs=libs Set a list of libraries to use when linking with
66 #                             the PACKAGE
67 #  --without-PACKAGE        Do not include support for the PACKAGE
68 EXTRA_OECONF = "--prefix=${prefix} \
69                 --docDir=${docdir}/${P} \
70                 --incDir=${includedir} \
71                 --libDir=${libdir} \
72                 --sbinDir=${sbindir} \
73                 --webDir=${localstatedir}/www \
74                 --build=${APPWEB_BUILD} \
75                 --host=${APPWEB_HOST} \
76                 --enable-keep-alive \
77                 --enable-multi-thread \
78                 --with-cgi=builtin \
79                 --enable-cookie \
80                 --enable-config-parse \
81                 --enable-config-save \
82                 --enable-digest-auth \
83                 --without-ssl \
84 --with-php5='loadable' \
85 --with-php5-dir='../../php-5.0.5-r0/php-5.0.5/libs' \
86 --with-php5-libs='php5 crypt expat xml2 m mysqlclient z' \
87 --with-php5-iflags='-I$(BLD_TOP)/$(BLD_PHP5_DIR)/.. -I$(BLD_TOP)/$(BLD_PHP5_DIR)/../main -I$(BLD_TOP)/$(BLD_PHP5_DIR)/../Zend -I$(BLD_TOP)/$(BLD_PHP5_DIR)/../TSRM'"
88
89 export IFLAGS = "${CPPFLAGS}"
90 export CC_FOR_BUILD = "${BUILD_CC}"
91 export LD_FOR_BUILD = "${BUILD_LD}"
92
93 LD_LIBRARY_PATH_prepend = "${S}/lib:"
94 LD_LIBRARY_PATH[export] = "1"
95 do_configure () {
96         ./configure ${EXTRA_OECONF}
97 }
98
99 do_compile () {
100         sed -i 's:MAKE_IFLAGS:MAKE_LDFLAGS = -L${STAGING_LIBDIR}\nMAKE_IFLAGS:' ${S}/http/modules/php5/Makefile
101 #       find ${S} -type f | xargs sed -i 's:-I${STAGING_INCDIR}:-I${STAGING_INCDIR} -I../../../../../php-5.0.5-r0/php-5.0.5 -I../../../../../php-5.0.5-r0/php-5.0.5/Zend -I../../../../../php-5.0.5-r0/php-5.0.5/TSRM -I../../../../../php-5.0.5-r0/php-5.0.5/main:'
102 #       sed -i 's:/usr/lib:${STAGING_LIBDIR}:' ${S}/http/package/LINUX/http.files
103 #       sed -i 's:cpmod ${STAGING_LIBDIR}/:cpmod :' ${S}/http/package/LINUX/http.files
104         oe_runmake build
105         oe_runmake compile
106 }
107
108 do_stage () {
109         :
110 }
111
112 do_install () {
113         oe_runmake 'ROOT_DIR=${D}' install-all
114 }
115
116 #do_install () {
117 #       install -d ${D}${sbindir} ${D}${sysconfdir}/appWeb/lib \
118 #                  ${D}${libexecdir}/appWeb ${D}${libdir}
119 #       install -m 0755 appWeb/appWeb ${D}${sbindir}/
120 #       install -m 0644 appWeb/appWeb.conf ${D}${sysconfdir}/appWeb/
121 #       install -m 0755 bin/${APPWEB_OS}/* ${D}${libexecdir}/appWeb/
122 #       install -m 0755 lib/lib*.so* ${D}${sysconfdir}/appWeb/lib/
123 #}