increase dvbapp PR.
[vuplus_openembedded] / recipes / angstrom / exquisite-theme-angstrom.bb
1 DDESCRIPTION = "Angstrom theme for exquisite"
2 HOMEPAGE = "http://www.enlightenment.org"
3 LICENSE = "MIT/BSD"
4 SECTION = "x11"
5
6 DEPENDS = "edje-native"
7 RRECOMMENDS_${PN} = "exquisite"
8
9 PV = "1.1"
10
11 inherit update-alternatives
12
13 ALTERNATIVE_NAME = "exquisite-config"
14 ALTERNATIVE_LINK = "${sysconfdir}/exquisite/config"
15 ALTERNATIVE_PATH = "${sysconfdir}/exquisite/config-angstrom"
16 ALTERNATIVE_PRIORITY = "20"
17
18 SRC_URI = "file://angstrom/"
19
20 S = "${WORKDIR}/angstrom"
21
22 do_compile() {
23    edje_cc exquisite-ang.edc angstrom.edj
24 }
25
26 do_install() {
27     install -d ${D}${sysconfdir}/exquisite
28     install -d ${D}${datadir}/exquisite/data/themes
29     install -m 0644 ${S}/angstrom.edj ${D}${datadir}/exquisite/data/themes/
30     echo 'THEME="-t angstrom"' > ${D}${sysconfdir}/exquisite/config-angstrom
31 }
32
33 PACKAGE_ARCH = "all"
34 CONFFILES_${PN} = "${sysconfdir}/exquisite/config-angstrom"
35 FILES_${PN} = "${sysconfdir}/exquisite ${datadir}/exquisite/data/themes"