increase dvbapp PR.
[vuplus_openembedded] / recipes / angstrom / angstrom-x11vnc-xinit.bb
1 DESCRIPTION = "Script to start a passwordless vnc of the current X session"
2 LICENSE = "MIT"
3 RDEPENDS = "x11vnc"
4
5 do_install() {
6         install -d ${D}/${sysconfdir}/X11/Xinit.d
7         echo "#!/bin/sh" > ${D}/${sysconfdir}/X11/Xinit.d/02vnc
8         echo "x11vnc  -q -bg -display :0 -forever -avahi" >> ${D}/${sysconfdir}/X11/Xinit.d/02vnc
9         chmod 0755 ${D}/${sysconfdir}/X11/Xinit.d/02vnc
10 }
11
12 CONFFILES_${PN} += "${sysconfdir}/X11/Xinit.d/02vnc"
13 PACKAGE_ARCH = "all"
14