increase dvbapp PR.
[vuplus_openembedded] / recipes / agg / agg_2.5.bb
1 DESCRIPTION = "Anti Grain Geometry - A High Quality Rendering Engine for C++"
2 AUTHOR = "mcseem@antigrain.com"
3 HOMEPAGE = "http://www.antigrain.com"
4 SECTION = "libs"
5 LICENSE = "AGG License"
6 DEPENDS = "virtual/libx11 virtual/libsdl freetype"
7
8 PR = "r2"
9
10 SRC_URI = "http://www.antigrain.com/${P}.tar.gz"
11 S = "${WORKDIR}/${P}"
12
13 inherit autotools pkgconfig
14
15 export SDL_CONFIG=${STAGING_BINDIR_CROSS}/sdl-config
16
17 CFLAGS += " -I${STAGING_INCDIR} "
18
19 PACKAGES =+ "${PN}-sdl ${PN}-x11"
20
21 FILES_${PN}-sdl = "${libdir}/libaggplatformsdl.so.*"
22 FILES_${PN}-x11 += "${libdir}/libaggplatformX11.so.*"
23 FILES_${PN} = "${libdir}/libagg.so.* \
24                ${libdir}/libaggfontfreetype.so.*"
25
26 LEAD_SONAME = "libagg.so"
27
28 EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/usr/include --x-libraries=${STAGING_INCDIR}/usr/lib"
29
30 do_stage() {
31     oe_libinstall -a -so libagg ${STAGING_LIBDIR}
32     oe_libinstall -a -so libaggfontfreetype ${STAGING_LIBDIR}
33     oe_libinstall -a -so libaggplatformX11 ${STAGING_LIBDIR}
34     oe_libinstall -a -so libaggplatformsdl ${STAGING_LIBDIR}
35     install -m 0644 libagg.m4 ${STAGING_DATADIR}/aclocal/
36     install -d ${STAGING_INCDIR}/agg2
37
38     for f in font_freetype font_win32_tt gpc
39     do
40             install -m 0644 ${S}/$f/*.h ${STAGING_INCDIR}/agg2/
41     done
42
43     cd include
44     headers=`find . -name "*.h"`
45     for f in $headers
46     do
47             install -D -m 0644 $f ${STAGING_INCDIR}/agg2/$f
48     done
49 }