Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / agg / agg-minimal_2.5.bb
1 DESCRIPTION = "Anti Grain Geometry - A High Quality Rendering Engine for C++"
2 AUTHOR = "mcseem@antigrain.com"
3 HOMEPAGE = "http://www.antigrain.com"
4 SECTION = "libs"
5 LICENSE = "AGG License"
6 DEPENDS = "freetype"
7
8 PR = "r0"
9
10 SRC_URI = "http://www.antigrain.com/agg-${PV}.tar.gz"
11 SRC_URI += "http://www.wxsvg.org/files/agg-2.5_cygming.patch;patch=1"
12 S = "${WORKDIR}/agg-${PV}"
13
14 inherit autotools pkgconfig
15
16 CFLAGS += " -I{$STAGING_INCDIR} "
17
18 FILES_${PN} = "${libdir}/libagg.so.* \
19                ${libdir}/libaggfontfreetype.so.*"
20
21 LEAD_SONAME = "libagg.so"
22
23 EXTRA_OECONF = "--disable-gpc --without-x --disable-examples --disable-ctrl \
24 --disable-platform --disable-win32tt --disable-sdltest"
25
26 do_stage() {
27     oe_libinstall -a -so libagg ${STAGING_LIBDIR}
28     oe_libinstall -a -so libaggfontfreetype ${STAGING_LIBDIR}
29     install -m 0644 libagg.m4 ${STAGING_DATADIR}/aclocal/
30     install -d ${STAGING_INCDIR}/agg2
31
32     for f in font_freetype font_win32_tt gpc
33     do
34             install -m 0644 ${S}/$f/*.h ${STAGING_INCDIR}/agg2/
35     done
36
37     cd include
38     headers=`find . -name "*.h"`
39     for f in $headers
40     do
41             install -D -m 0644 $f ${STAGING_INCDIR}/agg2/$f
42     done
43 }