Merge branch 'opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / abiword / abiword_2.8.1.bb
1 require abiword-2.5.inc
2
3 PR = "r4"
4
5 SRC_URI = "http://www.abisource.com/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
6            file://autogen-common.sh \
7            file://nodolt.patch;patch=1"
8
9 do_configure() {
10         autotools_do_configure
11 }
12
13 EXTRA_OECONF = " --disable-static  \
14                  --enable-plugins \
15                  --enable-collab-backend-xmpp \
16                  --enable-collab-backend-tcp \
17                  --enable-collab-backend-service \
18                  --with-libwmf-config=${STAGING_DIR} \
19 "
20 DEPENDS += " libwmf-native gtkmathview "
21 RCONFLICTS = "abiword-embedded"
22
23 FILES_${PN}                     += "${libdir}/libabiword-*.so ${datadir}/mime-info ${datadir}/abiword-${SHRT_VER}/certs ${datadir}/abiword-${SHRT_VER}/ui ${datadir}/abiword-${SHRT_VER}/xsl* ${datadir}/abiword-${SHRT_VER}/mime-info ${datadir}/abiword-${SHRT_VER}/Pr*.xml"
24 FILES_abiword-strings           += "${datadir}/abiword-${SHRT_VER}/strings"
25 FILES_abiword-systemprofiles    += "${datadir}/abiword-${SHRT_VER}/system.profile*"
26
27 PACKAGES_DYNAMIC = "abiword-meta abiword-plugin-*"
28
29 do_configure_prepend () {
30         install -m 0755 ${WORKDIR}/autogen-common.sh ${S}/autogen-common.sh
31         cd ${S}
32         ./autogen-common.sh
33 }
34
35 python populate_packages_prepend () {
36         abiword_libdir    = bb.data.expand('${libdir}/abiword-2.8/plugins', d)
37         do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
38
39         metapkg = "abiword-meta"
40         bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d)
41         bb.data.setVar('FILES_' + metapkg, "", d)
42         blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
43         metapkg_rdepends = []
44         packages = bb.data.getVar('PACKAGES', d, 1).split()
45         for pkg in packages[1:]:
46                 if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
47                         print "Modifying ", pkg
48                         metapkg_rdepends.append(pkg)
49         bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
50         bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d)
51         packages.append(metapkg)
52         bb.data.setVar('PACKAGES', ' '.join(packages), d)
53 }
54
55 FILES_${PN}-dev += "${libdir}/abiword-${SHRT_VER}/plugins/*.la"
56 FILES_${PN}-dbg += "${libdir}/abiword-${SHRT_VER}/plugins/.debug"
57